注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

Code@Pig Home

喜欢背着一袋Code傻笑的Pig .. 忧美.欢笑.记忆.忘却 .之. 角落

 
 
 

日志

 
 

[mac] Lion + Xcode4 在 terminal 上找不到 gcc 了  

2012-06-02 21:08:21|  分类: mac |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
最近重装了苹果系统,发现 terminal 上直接 gcc 无效了。搞了个替代方案。

~> cat ~/.profile 
PATH=$PATH:/Applications/Xcode.app/Contents/Developer/usr/bin


Makefile 还得这样写

~/sandbox/cpp> cat Makefile 
all:
    g++ -I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk/usr/include -I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk/usr/include/c++/4.2.1 -Wall test.cpp -L/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk/usr/lib


悲剧啊~

实在受不了了,改用 link。默认已有 /usr/lib 目录,所以改link到 /usr/local/lib 

ln -s /usr/include /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk/usr/include
ln -s /usr/local/lib /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk/usr/lib


正解
万能的google,总算找到正确的方法了。以前不装Xcode是没有command-line版本的gcc的,然后社区搞了个山寨版command-line,苹果想想,还是出个官方版吧,从Xcode 4.3.x开始出了个官方的command line for macos。详细看这里
如果不想装 XCode,去苹果官方下载个 command-line 版本即可
装了 XCode 4 的,可以从 Preferences -> Download 页面安装
  评论这张
 
阅读(1819)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017